Posts Tagged 'hardware'

Power Supply, Interrupted

Perhaps you remember my numerous computer problems.  My server died in 2007.  Shawn graciously replaced it with the donation of a freaking awesome machine that I honestly haven’t had the time to prep, but I will.  My latest build crapped out in like Feb 2008.  I replaced most every major component in the box, some twice, and eventually it rose as a Phoenix from the ashes of my desire to mess with it anymore (but, no, it wasn’t literally a bird on fire… or was it?).  Well, weekend before Christmas we trekked up to Carlinville for the Schuette family early Christmas and upon returning, the computer was off.  This actually happens relatively often… power outages generally overextend the capacity of my UPS, so I turned the UPS back on.  It’s nothing special, a CyberPower brick from Best Buy.  Well, after a few seconds, it started chirping, so I switched it to the other plug in the outlet (the non-battery surge strip that I swapped with worked fine in both), and no joy.  I figured the battery had completely discharged, so I let it charge up for a few hours.  Now when I turned it on, it would go about 5 seconds, chip, then turn back on.  Did that probably 10 times in a row before it turned itself off.

Now, I’m sure I’m crazy, but my thought is that a battery backup could certainly degrade into a simple power strip in the event of “battery no chargey”.  I mean, it gets power from the wall, it has six (or eight?) outlets… figure it out.  Oops, battery is out, let’s bypass that circuit and just send the juice through the line filter and to the plugs.  Nope, try as I might, I couldn’t get it to be any more or less than a hefty and super annoying outlet tester.  My guess is the battery is shot.  My guess is the battery is the single most expensive component there… power strip – $5, UPS – $60, and UPS = power strip + battery.  My guess is I won’t be that interested in fixing a low-end UPS.  Found a simple, unassuming power strip and all is well.

So, if anyone reads this and cares… is it odd that a UPS sans battery can’t function as a power strip?  I suppose if you had servers attached to it you wouldn’t want it NOT complaining if the battery were shot.  It’s not like this is something a huge operations center would (should) use, though.  At least give me a “y’know what, I’m gonna chance it” switch to bypass the “without a battery I’m nothing” circuitry.  Anyone looking for an Interruptible Power Supply?  An Uninterruptible Lack-of-Power Supply?  A paperweight?  A flail?  A good time?  Wait, what?

It Lives!

My computer is a computer again.  Only two months and I think it’s back to its former self.  So, absolutely the power supply and motherboard were shot.  Not sure what happened.  Not sure if they were related.  Was pretty dusty, the mobo mabye just shorted out somewhere.  New power supply was a steal at Radio Shack, $35.  I bought a new CPU, which may or may not have been needed, but $35 later I have the fastest single core Socket 939 chip available (Athlon 64 4000+) – only 3 years old by now!  There are very few Socket 939 motherboards left for sale, mostly the higher end ones with SLI or Crossfire support, and mostly north of $150.  But, I was able to find a Tyan model for only $45.  Of course, there had to be a problem (I discovered after receiving it)… it needs an additional 8-pin ATX power connector.  The new power supply did not have one.  So, I dropped another $80 on a PSU that has one.

Get that all set up (replacing a motherboard is tantamount to building a new computer from scratch) and it won’t boot.  Well, it does POST and I can configure the BIOS, so the parts are all working.  And it does boot to the Windows boot menu, but will never get any further (not even safe mode).  So, I pray that the hard drive didn’t get hosed.  Start up the recovery console and I can see that things are still there where they should be, which was a relief.  Of course, I’ve never actually used the recovery console before, so I have no idea what to do to recover from an error that I can’t really describe.

So, I let it sit for a few weeks.  I figure I’ll find another hard drive to toss in, install windows on that and not lose data from the old drive.  When I got time, I slapped an old 30 gigger in, and nothing.  So, I grabbed the 80 GB drive from a computer that was marked for the dumpster (thanks Shawn!) and slightly more than nothing.  BIOS can read the manufacturer information from the drive, but Windows Setup can’t use it to install Windows.  So, I talked to a few people and arranged a couple loaners once they got cleaned off.

In the meantime, I was pleading with Google to tell me how to fix this and the great and powerful Google offered me a soupcon of hope.  I don’t really install Windows that often, but I had remembered something to recover or repair an installation.  I just assumed it was the recovery console, and forgot about it.  I forgot that Windows Setup could actually repair an installation.  I never had a drive or partition I even thought about sacraficing, so I never took that leap into “setup Windows XP now”.  Per the repair guide above, I did a repair installation, and boom, it’s all good.  Got XP Service Pack 3 set up and few other updates, and all seems to be well.  Windows Setup repair, gasp, just worked.  I don’t know what the problem was (I did try rebuilding the MBR before the repair), but it wasn’t beyond repair.  Total pricetag, $221.92 with all the shipping and thermal paste and whatnot.  My father-in-law just bought an eMachines system, dual core, 2gb, decent hard drive space, 19″ widescreen monitor, new printer… $500.  Why do I build computers again?

Computer updates

So my computer died.  That sucks, and so far, it really makes me want to give up building computers and really lots of other things to do with computers.  It’s just frustration, really not much more benefit anymore.

Anyway, right when it happened, I tried turning it on, no dice.  Just absolutely nothing, no lights, no fans.  So, I figured power supply and replaced it.  Hey, now lights come on and fans spin up.  I hear a little hard drive action, but the monitors never get signal.  No POST noises or anything but lights and constantly on fans.  Take the CPU out and I hear a diagnostic message about a missing CPU, so I guess that’s the problem.  Buy a new three-year-old CPU, heat sink, and good thermal interface material.  Drop the new chip in, grease it up, and lock the heat sink in place.  No change at all.  Same lights.  Same fans.  Same hard drive action.

So, at this point, I’m not sure what to do.  I don’t have the time or resources to fully test the components and see what the problem really is.  I’ve ordered a new mobo, which brings me up to about $170 on revamping an aging system.  I probably have two good single core socket 939 processors, but few people want those anymore.  If this new mobo doesn’t fix it, I may just try and sell the lot of it and take some (more) time off from computer ownership.

So many times computer geek type people want things to “just work”, but I find most often they just don’t.  I won’t delude myself into thinking that a computer built by someone else will work any better, it will just contain lower quality parts, but I guess I can get a warranty. And, if I wanted a Mac, I’d let you know…


Posts

February 2017
S M T W T F S
« Jun    
 1234
567891011
12131415161718
19202122232425
262728  

del.icio.us bookmarks

Thanks

I would like to thank Mike Hellrich for hosting a couple redirects for me while I sort out my web server problems.